Jump to content


Photo

Engine Fault - Turbo


  • Please log in to reply
5 replies to this topic

#1 telfordwhite

telfordwhite

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 October 2008 - 01:26 PM

Help would be very much appreciated.

Picked up my Cit Xsara picasso 1.6 Diesel 2 weeks ago and was very pleased with it.

However 2 days ago the "Engine fault" message appeared and recurred each time I started the car up though there is no obvious loss of performance.


To cut a long story short the Warranty company are quibbling with the citroen dealer about the repair (turbo needs replacing at considerable cost).

I am now awaiting an Engineers inspection from the warranty company but the fault message is no longer being displayed.

I know of other owners who have had a similar problem which was diagnosed as being "nothing." or at least a very minor fault, so is this a common fault warning and are the Dealers likely to be pulling a fast one on the warranty company.

My main concern is that the warranty company will disagree with the Dealer and I will then have a recurring unsolvable problem.

Thanks in anticipation.
  • 0

#2 techbod

techbod

    Advanced Member

  • Members
  • PipPipPip
  • 1177 posts

Posted 29 October 2008 - 01:39 PM

sounds to me like a scam why didn't they get a printout of the fault code for proof that its the turbo ( which I doubt there's a problem )? no light on now suggests to me it was a bogus fault but it should still have a soft error code stored in the ECU ask them to diagnose it again and ask for a readout, its an old cash trick by garages like the EGR valve needs changing when they know it can be cleaned so it comes down to cost :lol:
  • 0

#3 telfordwhite

telfordwhite

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 October 2008 - 06:09 PM

Yeah, that is possibly what is happening. Will be interesting to see what the Warranty Company Engineer thinks.

Will let you know how it's resolved, cheers
  • 0

#4 techbod

techbod

    Advanced Member

  • Members
  • PipPipPip
  • 1177 posts

Posted 30 October 2008 - 10:31 AM

it should be covered by the warranty :)
  • 0

#5 Guest_Jessie the Cat_*

Guest_Jessie the Cat_*
  • Guests

Posted 13 November 2008 - 06:16 PM

Help would be very much appreciated.

Picked up my Cit Xsara picasso 1.6 Diesel 2 weeks ago and was very pleased with it.

However 2 days ago the "Engine fault" message appeared and recurred each time I started the car up though there is no obvious loss of performance.
To cut a long story short the Warranty company are quibbling with the citroen dealer about the repair (turbo needs replacing at considerable cost).

I am now awaiting an Engineers inspection from the warranty company but the fault message is no longer being displayed.

I know of other owners who have had a similar problem which was diagnosed as being "nothing." or at least a very minor fault, so is this a common fault warning and are the Dealers likely to be pulling a fast one on the warranty company.

My main concern is that the warranty company will disagree with the Dealer and I will then have a recurring unsolvable problem.

Thanks in anticipation.



This is a serious fault. We had exactly this happen on our Picasso which is out of warranty but has done less than 60K miles. We do not use the local Citroen garage because they are hopeless and expensive but my usual garage could not find out what was wrong - because the light had gone out again. To cut a long story short, I eventually took it to a Citroen specialist who found a valve had stuck and the BEM needed replacing - cost nearly £800. On the next long drive, the fault light came on again and the car went into economy mode - ie virtually no power. This should have happened the first time but the BEM is faulty. Cost of turbo replacement - over £1200. I have contacted Citroen who don't care and just try to wriggle out of their responsibilities. This is a known and recurring fault and I believe there should be a recall.

I am now contacting motoring journals to see if they will spread the word to get any other people with this problem to contact me and then I will sue Citroen in the small claims court, using the other reports as evidence. I've had Citroens for over thirty years - this is my seventh - and my last. So if you have had this problem, contact me on a special e-mail address I have set up - xsaraturbofighter@yahoo.co.uk. Thanks :D

#6 telfordwhite

telfordwhite

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 27 December 2008 - 06:20 PM

Sorry to hear about your problem. Luckily for me the Sellers of my traded in Picasso (Pentagon Vauxhall) have been brilliant and honoured their committments as sellers and replaced the turbo as well as the fly wheel which had also gone.

Very pleased with the service i got considering they would have made very little on the car.
  • 0




Ford Galaxy Owner Club