Jump to content


If this site has saved you money please feel free to donate a little of the saving


Great value Unlimited Broadband from an award winning provider


Photo

2008 2.2 Relay Heater Fan Issues?


  • Please log in to reply
1 reply to this topic

#1 carl13671

carl13671

    Member

  • Members
  • PipPip
  • 24 posts
  • Gender:Male

Posted 01 January 2019 - 04:45 PM

Hello again,

Happy New Year and hope your all well,,,

 

My heater fan has suddenly stopped working and I am having starting issues.(not sure if these are related).

The heater has no power at the resistor multi-plug so I went to the plug behind the dash controls and checked which also has no power to it.

I have checked all the fuses but cant seem to find anything related to the heater fan.

Has anybody had similar problems with their van?

Also intermittently over the last couple week when starting there has been nothing at the key.All the ignition and dash is working but nothing when turned to start,Its not a battery problem and i am not 100% sure its a starter motor problem because I changed it 14 months ago. 

Ive read somewhere about all the fan power is taken from the key switch and this was a problem on older Relays,can somebody shine any light on this?

 

Thanks in advance for any help

Carl


  • 0

#2 paul.h

paul.h

    Moderator

  • Validating
  • PipPipPip
  • 6,784 posts
  • Gender:Male

Posted 02 January 2019 - 11:43 AM

I am not sure about the Relay, but I remember something about the Xsara Picasso. If the pollen filter is not changed regularly it puts a strain on the fan which can cause a problem with the ignition switch. If your filter has not been changed then it might be something similar. Some info here and it seems a relay was not used for the fan https://frenchcarfor...pic.php?t=50146  and here http://www.citroenpi...n-switch-kaput/






Ford Galaxy Owner Club