Jump to content


Berlingo Van Central Locking Fault


  • Please log in to reply
6 replies to this topic

#1 Guest_Mark-Rainey_*

Guest_Mark-Rainey_*
  • Guests

Posted 06 April 2011 - 10:47 AM

My 05 Berlingo van has developed a fault where it won't lock with the central locking. Has anyone got a solution or suggestion? Thanks in advance

#2 kfk

kfk

    Expert in explaining the use of the Owners Handbook

  • Admin
  • PipPipPip
  • 1218 posts
  • Gender:Male

Posted 07 April 2011 - 06:09 AM

My 05 Berlingo van has developed a fault where it won't lock with the central locking. Has anyone got a solution or suggestion? Thanks in advance


key in lock and wont work or point and press key wont work?

do they lock and bounce back open, does only one doore lock?

if you try key in other door does it work/do anything different

if you press button on dash what happens?

does the interior light stay on? when door is closed?
  • 0

#3 Guest_Mark-Rainey_*

Guest_Mark-Rainey_*
  • Guests

Posted 07 April 2011 - 08:15 PM

Here goes then lol:
- Nothing opens with the remote key but the indictator lights flash
- The key opens each door individually but not together
- The button on the dash doesn't open or close anything
- When the key is in the drivers door it will lock both front doors but not the rear doors
- When the remote button is hit to lock it locks both front doors.

Help lol

#4 kfk

kfk

    Expert in explaining the use of the Owners Handbook

  • Admin
  • PipPipPip
  • 1218 posts
  • Gender:Male

Posted 07 April 2011 - 09:40 PM

Here goes then lol:
- Nothing opens with the remote key but the indictator lights flash
- The key opens each door individually but not together
- The button on the dash doesn't open or close anything
- When the key is in the drivers door it will lock both front doors but not the rear doors
- When the remote button is hit to lock it locks both front doors.

Help lol


ok......
- so the central locking is recieving an unlock signal from the remote key....because the indicators flash
- when the key is locking the drivers door they both lock.....but when you unlock only the door the key is in will open.......drivers door lock not sending a signal to the BSI to unlock doors?
- sounds like the rear door locking is a separate problem

As a cheap first suggestion.........check the wiring harness that runs in the rubber gaitor between the drivers door and car body...your looking for broken wires
also do the same at the rear doors.
  • 0

#5 Guest_Mark-Rainey_*

Guest_Mark-Rainey_*
  • Guests

Posted 07 April 2011 - 09:51 PM

It's a nightmare, would Citroën diagnostics hold the answer? The wiring has been checked by an auto spark and he says all is well

#6 kfk

kfk

    Expert in explaining the use of the Owners Handbook

  • Admin
  • PipPipPip
  • 1218 posts
  • Gender:Male

Posted 08 April 2011 - 06:04 AM

It's a nightmare, would Citroën diagnostics hold the answer? The wiring has been checked by an auto spark and he says all is well



the rear door is a simple 2 wire motor......it either has 12v supply and an earth or it doesnt......maybe go see if it has, you only need a cheap multimeter or led light tester to check this.......if you have 12v and earth when the central locking is operated then the answer may well be in the motor faulty.

if you think the motor is faulty you can test it before you order a new one by removing from the vehicle and giving it a seperate power supply down 2 wires fro the battery.
  • 0

#7 Guest_Mark-Rainey_*

Guest_Mark-Rainey_*
  • Guests

Posted 08 April 2011 - 10:57 AM

I ordered a new actuator and test fitted it and it done the same thing so I gave back to the dealer. Its a head scratcher l




Ford Galaxy Owner Club